Script Mikrotik ป้องกันการโจมตี Brute force login SSH เป็น Script ปิดการโจมตี Brute force login การทำงาน Brute force attack จะโจมตีได้ก็ต่อเมื่อได้ username ผ่านคนที่ใช้ U:admin หรือ root ก็จะโดน Brute force attack โจมตีเป็นลำดับต่อไป
ถ้าใช้รหัสเป็นตัวเลข 4 ตัว เช่น 1234 ก็ใช้เวลาในการสุ่มเดา 11.11 วินาที
ถ้าใช้รหัสเป็นตัวเลข 6 ตัว เช่น 123456 ก็ใช้เวลาในการเดา 18.52 นาที
ถ้าใช้รหัสเป็นตัวเลข 8 ตัววันเดือนปีเกิด เช่น 12122527 ใช้เวลา 1 วัน
ถ้าใช้รหัสเป็นตัวเลข 10 ตัว เบอร์มือถือ เช่น 0891234567 ใช้เวลา 4 เดือน
น่ากลัวใช่ไหมครับ การโจมตี Brute force โดยกลุ่มผู้ไม่หวังดีจะใช้โปรแกรมยิงมายัง IP เรื่องเป้าหมาย

/ip firewall filter
add chain=input protocol=tcp dst-port=22 src-address-list=ssh_blacklist action=drop comment="drop ssh brute forcers" disabled=no
add chain=input protocol=tcp dst-port=22 connection-state=new src-address-list=ssh_stage3 action=add-src-to-address-list address-list=ssh_blacklist address-list-timeout=1d disabled=no
add chain=input protocol=tcp dst-port=22 connection-state=new src-address-list=ssh_stage2 action=add-src-to-address-list address-list=ssh_stage3 address-list-timeout=1m disabled=no
add chain=input protocol=tcp dst-port=22 connection-state=new src-address-list=ssh_stage1 action=add-src-to-address-list address-list=ssh_stage2 address-list-timeout=1m disabled=no
add chain=input protocol=tcp dst-port=22 connection-state=new action=add-src-to-address-list address-list=ssh_stage1 address-list-timeout=1m disabled=no

Advertisements
Advertisements

Comments powered by CComment

Star InactiveStar InactiveStar InactiveStar InactiveStar Inactive