ดาวไม่ได้ใช้งานดาวไม่ได้ใช้งานดาวไม่ได้ใช้งานดาวไม่ได้ใช้งานดาวไม่ได้ใช้งาน
 

############  Start  Block Bittorrent Layer7  เปลี่ยน IP Address ตามการใช้งานจริง นอกนั้น คงไว้เหมือนเดิม ############

/ip firewall layer7-protocol add name=.Bittorrent regexp="^(\\x13bittorrent protocol|azver\\x01\$|get /scrape\\\?info_hash=get /announce\\\?info_hash=|get /client/bitcomet/|GET /data\\\?fid=)|d1:ad2:id20:|\\x08'7P\\)[RP]"
/ip firewall filter add action=add-src-to-address-list address-list=Bit-Addr address-list-timeout=1m chain=forward disabled=no hotspot="" p2p=bit-torrent src-address=10.10.0.0/20 src-address-list=!Bit-Addr-Unblock
/ip firewall filter add action=add-src-to-address-list address-list=Bit-Addr address-list-timeout=1m chain=forward disabled=no dst-address-type="" layer7-protocol=.Bittorrent src-address=10.10.0.0/20 src-address-list=!Bit-Addr-Unblock src-address-type=local
/ip firewall filter add action=add-dst-to-address-list address-list=Bit-Source address-list-timeout=1m chain=forward disabled=no dst-address-list=!Bit-Addr-Unblock hotspot="" p2p=bit-torrent src-address=10.10.0.0/20
/ip firewall filter add action=add-dst-to-address-list address-list=Bit-Source address-list-timeout=1m chain=forward disabled=no dst-address-list=!Bit-Addr-Unblock dst-address-type="" layer7-protocol=.Bittorrent src-address=10.10.0.0/20 src-address-type=local
/ip firewall filter add action=drop chain=forward disabled=no dst-port=30000-65535 protocol=udp src-address-list=Bit-Addr
/ip firewall filter add action=drop chain=forward packet-mark=bit-in
/ip firewall mangle add action=mark-connection chain=forward dst-address-list=Bit-Addr new-connection-mark=bit-in src-address-list=Bit-Source
/ip firewall mangle add action=mark-connection chain=forward dst-address-list=Bit-Source new-connection-mark=bit-in src-address-list=Bit-Addr
/ip firewall mangle add action=mark-packet chain=forward connection-mark=bit-in new-packet-mark=bit-in passthrough=no
/ip firewall mangle add action=drop chain=forward dst-address-list=Bit-Source src-address-list=Bit-Addr

############  END  Block Bittorrent  ############